• Liebe User mit web.de oder gmx.de E-Mail-Adressen: Bitte ändert eure Adressen, da wir nicht garantieren können das E-Mails vom Forum an euch ankommen. Genaueres dazu im Feedbackforum
  • Liebe Community,
    am 21.04.2021 wird unsere Domain in ein neues Rechenzentrum umziehen.
    Daher wird das Forum zwischen 00:00 und 04:00 Uhr nicht unter broodwar.net erreichbar sein,
    stattdessen könnt ihr das Forum unter https://85.214.102.212/forum/ ansurfen. Beachtet dabei bitte, dass ihr euch dafür extra einloggen müsst.
    Sobald alles erledigt ist, sind wir ganz normal wieder erreichbar.

Excel: Zählenwenn in Spalte über mehrere Seiten

Mitglied seit
13.02.2003
Beiträge
3.788
Reaktionen
3
Ort
Münster
Ich möchte in Excel zählen lassen, wie oft ein Text in einer Spalte vorkommt. Diese Spalte ist in mehreren Sheets in der gleichen Datei identisch. Folgende Aufgabenstellung:

Stellt euch einfach vor, Shi hätte eine Liste von Usern gemacht, diese alphabetisch sotiert und in Blatt User #01 stehen alle mit A, in Blatt User #02 stehen alle mit B., etc. bis User #24 mit Z
In Spalte K trägt Shi in jedem Blatt seine persönliche Meinung zum jeweiligen User ein, als Freitext. Jetzt möchte Shi herausfinden, wieviele Trottel sich im Forum bewegen und versucht es mit folgender Formel:

=ZÄHLENWENN('User #01:User #24'!K2:K51;"Trottel")

Leider kommt die Fehlermeldung #Wert!

Was nu?
 
Zuletzt bearbeitet:
Mitglied seit
21.09.2001
Beiträge
3.433
Reaktionen
1.999
brudi gib her ich bau dir das in 5 min :troll: allerdings excel nativ wird schwer brauchst schon vbs fürn regex match
 
Mitglied seit
04.01.2004
Beiträge
1.480
Reaktionen
0
Folgendes sollte funktionieren:

Schreibe in Zelle A1 01, in B1 02, in C1 03 usw. bis 26 (damit dir Excel die 0 bei 01 usw. nicht automatisch löscht, kannst du '01 schreiben)

Dann in die Zelle A2 folgende Formel:

=ZÄHLENWENN(INDIREKT("'User #"&A1&"'!K:K");"Trottel")

Danach ziehst du die Formel nach rechts bis Spalte 26 und summierst in der 27ten Spalte die Spalten 1 bis 26 dann auf.

Zur Erklärung: Mit indirekt kannst du Texte zusammenbauen und dabei Teile des Textes aus Zellwerten bestehen lassen. Indirekt baut hier also den Text zusammen aus User # und dann den Wert aus A1 (was ja 01 ist). Das Ergebnis ist daher User #01. Das hat den Vorteil, dass man so dynamisch Texte zusammenbauen kann.
 
Zuletzt bearbeitet:
Oben